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1 GT202 Development Kit Contents 

The GT202 development kit contains: 

� GT202 Kit  

� Gt202 Wi-Fi Module  (Soldered on Freedom Adaptor) 

� Freedom Adaptor 

� Freescale K22F120M Freedom Development Platform 

� USB cable 

 

  

GT202 development kit 

.
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2 Quick Setup 

 

This chapter describes the procedures to setup the GT202 development platform. Once the setup is 

complete, the GT202 development platform is ready to be installed with demo applications that can be run 

to evaluate the functionality and performance of the GT202 Wi-Fi module.  

 

2.1 Download and install the mbedOpenSDAv2.1 USB driver 
 

FRDM-K22F comes with the mass-storage device (MSD) Flash Programmer OpenSDAv2.1 Application 

preinstalled. The MSD Flash Programmer is a composite USB application that provides a virtual serial port 

and an easy and convenient way to program applications into the K22F MCU. It emulates a FAT file 

system, appearing as a removable drive in the host file system with a volume label of MBED. Raw binary 

or Motorola S-record files that are copied to the drive are programmed directly into the flash of the K22F 

and executed automatically. The virtual serial port enumerates as a standard serial port device that can be 

opened with standard serial terminal applications. 

1. Download and install the mbedOpenSDAv2.1 USB drivers found at: 

http://mbed.org/handbook/Windows-serial-configuration  

2. Put together the GT202-kit with the FRDM-K22F120M through the freedom connector. 

 

 

+

 

 

 = 
 

 

3. Plug in a USB cable from a USB host (PC) to the OpenSDAv2.1 Micro-AB USB connector (J5). The 

FRDM-K22F will be powered by this USB connection. 
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4. USB host (PC) will start initializing the OpenSDA USB driver. After the driver is initialized and 

installed, a removable drive in the USB host file system will appear with a volume label of MBED. 

 

 

5. Download throughput_demo.bin from http://download.arrow.com: 

� GT202 MQX (3.0.2) Throughput Demo - IoE GT202 Wi-Fi Module MQX Throughput Demo for 

FRDM-K22F120M 

6. Unzip the throughput_demo.bin from the downloaded zip package. 

7. Copy throughput_demo.bin to the removable drive with a volume label of MBED. OpenSDA MSD 

flash programmer will flash the .bin file onto the flash on FRDM-K22F 

 

 

8. Reset the FRDM-K22F by removing the USB cable and re-insert.  

9. The Throughput demo is now running on the FRDM-K22F. 

2.2 Connect to Throughput Demo Console 

Determine the symbolic name assigned to the FRDM-K22F virtual serial port. To do this in Windows, open 

Device Manager and look for the COM port named “mbed Serial Port”. 
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1. Start a terminal application from the PC and select the COM port (named “mbed Serial Port”) 

to connect using the port setting 115200, 8, n, 1, no flow control.  

2. The serial terminal application displays:  

 
shell >  

 

3. The console connection is established. Type the following command at the terminal to view 
the version information. The driver and the firmware versions can be different. 

 

wmiconfig –-version 

 

4. To connect to a Wi-Fi access point  

 

wmiconfig --p passcode (please change to the password accordingly) 
  

wmiconfig --wpa 2 TKIP TKIP (assuming WPA2 is used, with TKIP) 
  

wmiconfig --connect AP-SSID (please change to the SSID of the AP accordingly 
  

Setting SSID to BLACK-WIDOW  

Connected 

4 way handshake success  

wmiconfig –-ipdhcp 

 

IP:192.168.1.10 Mask:255.255.255.0, Gateway:192.168.1.1 

 

 

5. Refer to GT202 MQX PDK Demo Applications User Guide for additional Throughput demo 

commands 
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3 Installing OS and Development Tools 

This chapter describes the procedures to install the RTOS (real-time operating system) and the 

development tools required for building the utilities and demo applications for the GT202 Development kit. 

3.1 Installing IAR embedded workbench for ARM® 

IAR Embedded Workbench is the IDE for developing applications targeted for a FRDM-K22F120M 

platform. The applications such as the throughput demo are provided as IAR workspace projects. 

1. Contact IAR support team to download the installer of the IAR Embedded Workbench for ARM v7.1. 

Later versions may work, but have not been verified.  

2. Install the IAR Embedded Workbench v7.1. 

3. Register a license for the IAR Embedded Workbench v7.1 through the IAR License Manager. 

a. Open the IAR License Manager from the Windows Start menu or from the IAR Embedded 

Workbench IDE. 

b. Select License → Get evaluation license. Follow the instructions to register a new license for 

version 7.10. 

4. Activate the license on the computer. 

In IAR License Manager, select License → Activate License and enter the license number. Follow the 

instructions to activate the license. 

3.2 Installing MQX4.1 RTOS for FRDM-K22F120M 

The MQX4.1 operating system, MQX patches, and the GT202 MQX PDK must be installed before 

compiling the utilities and applications. 
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Freescale Download Page 

http://www.freescale.com/webapp/connect/displayPartnerProfile.sp?partnerId=5640 

Download the following items from the page: 

� Freescale MQX RTOS 4.1.0 GA 

� Freescale MQX RTOS 4.1.0 FRDM-K22F120M GA 

� FRDM-K22F120M and GT202 Support Patch for Freescale MQX RTOS 4.1 

 

Arrow Software Download Site for GT202 PDK   

http://download.arrow.com 

Download the following item: 

� GT202 MQX (3.0.2) PDK - IoE GT202 Wi-Fi Module MQX Platform Development Kit for FRDM-

K22F120M  

3.2.1 Installing the Freescale MQX 4.1.0 operating system 

1. Download the installer of the MQX RTOS 4.1.0 GA from Freescale website. 

2. Run the OS installer FSLMQXOS_4_1_0_GA.exe and follow the instructions to install.  
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3.2.2 Installing the MQX RTOS 4.1.0 FRDM-K22F120M GA 

1. Download the installer of the MQX RTOS 4.1.0 FRDM-K22F120M GA from Freescale website. 

2. Run the patch installer FSLMQXOS_4_1_0_FRDMK22F120M.exe. 
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3. Set the destination to the MQX 4.1.0 OS installation directory and follow the instructions to 

complete the installation. 

   

3.2.3 Installing FRDM-K22F120M and GT202 Support Patch for Freescale MQX 
RTOS 4.1 

1. Download the installer of the FRDM-K22F120M and GT202 support patch from Freescale site. 

2. Run the patch installer Install_MQX4.1_Patches_GT202_3.0.2CS.exe. 

   

3. Set the destination to the MQX4.1.0 OS installation directory and follow the instructions to complete 

the installation. 
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3.2.4 Installing the GT202 MQX PDK 3.0.2 CS 

1. Download the GT202 MQX PDK 3.0.2 CS installer from Arrow support site 

(http://download.arrow.com)  

2. Run the driver installer Setup_MQX4.1_GT202_3.0.2CS.exe.  

   

3. Set the destination to the MQX 4.1.0 OS installation directory and follow the instructions to 

complete the installation. 

   
 

 

 

 

3.3 Installation directory structure 

After the OS, patches, and driver are correctly installed following the steps in section 3.2, the installation 

directory structure looks like: 

 

|--demo 

|  |--config_tool 

|        |--common 

|        |--custom 

|        |--driver_plugin 

|        |--sensor 

|   
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|  |--flash_agent 

|        |--bin 

|         

|  |--flash_config 

|        |--bin 

|        |--driver_plugin 

|        |--iar 

|        |--src 

|         

|  |--p2p_demo 

|        |--bin 

|        |--driver_plugin 

|        |--iar 

|        |--src 

|         

|  |--throughput_demo 

|        |--bin 

|        |--driver_plugin 

|        |--iar 

|        |--src 

|         

|  |--utf_agent 

|        |--bin 

|        |--driver_plugin 

|        |--iar 

|        |--src 

|         

|--FirmareUpdate 

|--mfs 

|  |--build  

|  |--source 

|  |--examples 

|   

|--mqx 

|  |--build  

|  |--source 

|  |--examples 

|   

|--rtcs 

|  |--build  

|  |--source 

|  |--examples 

|   

|--shell 

|  |--build  

|  |--source 

|  |--examples 

|   

. 

. 

. 

 



GT-202 MQX PDK 

 

Shenzhen Longsys Electronics Co.,Ltd www.Longsys.com 

8/F, 1 Building. Finance Base, NO.8, KeFa Road, Shenzhen, China   Tel: 86-755-86168848 

10/F, CHINA AEROSPACE CENTRE,143 HOI BUN ROAD,HKTel: 852-23850111 

14 

4 Building Utilities and Demo Applications 

4.1 Preparing the build environment 

The host driver is configured through a header file a_config.h. Since each demo application requires a 

slightly different driver configuration, the prepare_app.bat file shall be run at the beginning to copy the 

required configuration header file and ensure the appropriate links are in place for creating the proper build 

structure. 

1. Open a DOS command prompt with administrator privileges. 

2. Change to the installation directory. 

3. Run the <MQX_DIR>/prepare_app.bat from the installation directory and select an application.  

� 1 = Flash Agent 

� 2 = Throughput Demo 

� 3 = P2P Demo 
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4.2 Building BSP, PSP, RTCS, MFS, shell components 

This section describes the procedures to build the following components: 

� bsp_frdmk22f120m 

� psp_ frdmk22f120m 

� rtcs_ frdmk22f120m 

� mfs_ frdmk22f120m 

� shell_ frdmk22f120m 

To build the components: 

1. Double click the frdmk22f120m.eww file in the MQX installation folder to open the IAR IDE. 

 

2. Right click a project and select Set As Active. 

3. Right click the project and select Options….  

4. In General Options → Target → Device, click  to select the MCU model used on the FRDM-

K22F120M, Freescale MK22FN512xxx12.   

5. Save the project. 
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6. Right click the project and select Make to build. 

7. Repeat step 2 to 6 to build other components. 

4.3 Building throughput demo, flash agent, UTF agent 

This section describes the procedures to build the following application and utilities: 

� flash_agent 

� utf_agent 

� throughput_demo 

To build the applications: 

1. Run prepare_app.bat as described in section 4.1. 

2. Double click the frdmk22f120m.eww file in the MQX installation folder to open the IAR IDE. 

3. Right click a project and select Set As Active. 

4. Right click the project and select Options….  

5. In General Options → Target → Device, click  to select the MCU model used on the FRDM-

K22F120M, Freescale MK22FN512xxx12. 

6. Save the project. 

7. Right click the project and select Make to build. 

8. Repeat step 2 to 6 to build other applications. 

4.4 Building P2P demo 

This section describes the procedures to build the following demo application: 

� p2p_demo 

To compile the P2P demo application: 

1. Run prepare_app.bat as described in section 4.1  

2. Double click the frdmk22f120m.eww file in the MQX installation folder to open the IAR IDE.  

3. Rebuild BSP, PSP, RTCS, MFS, shell, and P2P demo in order, see section 4.2. 
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5 Downloading Images to FRDM-K22F120M 

FRDM-K22F platform can be loaded with OpenSDAv2.1 J-Link firmware for image download and 

application debugging tasks. Please refer to Quick Start Guide for the Freescale Freedom 

Development Platform FRDM-K22F (FRDM-K22F-QSG.pdf, available from FRDM-K22F120M 

product page on www.freescale.com ) on how to install JLink CDC UART Port and load J-link 

application firmware on FRDM-K22F. 

5.1 Downloading demo applications 

Before proceeding, ensure the demo applications are built following the steps in chapter 4. 

1. Open the workspace in the IAR IDE. 

� frdmk22f120m.eww: flash_agent, utf_agent, throughput_demo, p2p_demo 

2. Right click the demo project and select Option…. 

3. In Debugger → Setup tab, set Driver to J-Link/J-Trace. 

 

4. In Debugger -> J-Link/J-Trace -> Connection tab  
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5. Save the project. 

6. Right click the project and select Set As Active. 

7. Select Project → Download → Download and Debug to download and debug the demo application 

on FRDM-K22F. 

5.2 Flashing firmware image to GT202 

The GT202 module is preconfigured with a firmware image. To program a different firmware image, the 

following components are required: 

 

MCU flash agent Provided as an example project in software package. The agent interacts with an 
application running on a Windows machine over UART. 

host.exe A Windows-based programming tool that interacts with the agent running on the 
K22F MCU. The agent prepares the image by adding MAC address to the header 
and fragments the image in 1-Kbyte chunks and sends it to the MCU. 

flashotp.bin The release package include the following images based on the I/O and host: 

sp141_flashRead1IO_spiHost.bin 

Rename the corresponding bin file to flashotp.bin.  
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Firmware flashing setup 

1. Copy demo\flash_agent\bin\host.exe to a working directory. 

2. Copy the corresponding firmware image from demo\flash_config\bin\ to the working directory and 

rename it to flashotp.bin. 

3. Flash demo\flash_config\iar\frdmk22f120m\Int Flash Debug\Exe\flash_agent.out to the K22F MCU 

using the IAR embedded workbench.  

4. Reset the FRDM-K22F board. 

5. Invoke the host.exe program. 

6. Enter the COM port corresponding to the UART terminal in the format of COM<x>. The utility 

moves to the next step if the COM port is opened correctly; otherwise it prints an error and exits. 

7. Enter a MAC address in 12 hexadecimal digits without any special characters and confirm the address. 

If a MAC address is already programmed, the new address is ignored. 

8. Press Enter to use the default path for the firmware image. If the image and the host.exe utility are 

located at different paths, provide the path of the image. 

9. The host.exe tool starts the flash process and prints the results. If the OTP has been programmed 

before, it prints OTP not Written and continues to program the flash. 

 

 


